How can we improve Boxer for Android?

Bug: Outlook address cannot be correctly set up as exchange address

When I tried to set up an @outlook.com address, I recognized that using the Outlook option was not sufficient.
I was unable to use the great features of exchange.

When I tried to set it up with the exchange option I was automatically forwarded to the outlook option, since my address ended with @outlook.com.

This is not the way I would except the functionality.

I was only able to set it up as an exchange address with a little hack. I change the ending to @outlook.de, so the app was unable to establish a connection to a server.
I was then able to change the option to exchange and my address to @outlook.com.
The big ugly problem now is, that the name identifying this connection cannot be change at this stage of set up.
So the name remained @outlook.de, which I initially entered.
The service work though, so this is clear, that this @outlook.de thing is only a local identifier.

I would really really love to have this thing correct.

Kepp up the good work.

55 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    der-Daniel shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    15 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • R Peter commented  ·   ·  Flag as inappropriate

        Seems no way one can sync Live.com, Gmail.com or yahoo.com now.
        Unfortunate that is the default mail client in cyanogenmod

      • Anonymous commented  ·   ·  Flag as inappropriate

        If you set up a outlook.com account Boxer uses IMAP instead of ActiveSync. So Calender and Contacts are not Synced via this account.

      • Thomas commented  ·   ·  Flag as inappropriate

        This bug has made me completely abandon Boxer on CM12S for another client. If you remove the forceful defaulting to IMAP for any outlook, hotmail or live address, I may try it out again, however, in its current state, it's useless for my needs.

      • Anonymous commented  ·   ·  Flag as inappropriate

        This bug has made me completely abandon Boxer on CM12S for another client. If you remove the forceful defaulting to IMAP for any outlook, hotmail or live address, I may try it out again, however, in its current state, it's useless for my needs.

      • Alex Hurren commented  ·   ·  Flag as inappropriate

        Do we have any idea when this bug will be fixed, The Gmail App with Exchange Service 5.0 apk installed works as you would expect!

      • DD commented  ·   ·  Flag as inappropriate

        Even with the workaround I cannot get outlook.com to work with exchange. It Always asks for a port.
        Can someone tell me which settings to use for outlook.com exchange?
        (I have cm12s which has Boxer as standard email app.)

      • der-Daniel commented  ·   ·  Flag as inappropriate

        Thanks for replying.
        A straightforward solution would be, to just allow choosing the protocol before entering the mail address or make auto-detecting optional.

      Feedback and Knowledge Base